wiki:TUI

TUI information

Python dependencies for linux users

TUI has strict python dependencies. Many linux users have problems displaying guider or slitviewer images because they have the wrong version of one or more packages. Even if TUI is built correctly, running it from the wrong directory might result in a different package being loaded. Since individual linux and python setups can vary widely, the same solution might not work for everyone. But here are some solutions that have worked for some people.

Pre-built TUI 2.6.0

Download a copy of TUI pre-built for linux as of December 2017 at

http://www.apo.nmsu.edu/35m_operations/TUI-images/files/tui-centOS.tar.xz

Future TUI versions will be linked from the TUI-images web page so be sure to check there also.

Install from the ground up

(1) install miniconda2 using the usual installer
(2) in miniconda2/bin do "./conda install python=2.7.12" to revert to
python 2.7.12
(3) create a file "pinned" in miniconda2/conda-meta with the line ``python
==2.7.12"
(4) in miniconda2/bin do "./conda install numpy=1.8.2" to install numpy
1.8.2
(5) add line "numpy ==1.8.2" to "pinned"
(6) in miniconda2/bin do "./conda install matplotlib"
(7) in miniconda2/bin do "./conda install Pillow"
(8) in miniconda2/bin do "./conda install astropy"
(9) in miniconda2/bin do "./pip install pygame"
(10) in miniconda2/bin do "./pip install RO==3.6.9”

Forcing package version at runtime

Last modified 13 months ago Last modified on Mar 22, 2018, 3:06:26 PM